之前有客户要求,把电信链路配置为上网主要链路, 联通 链路则作为备份使用,我虽然觉得很浪费,但还是照做了,因为客户总会有自己的考虑。

配置完成交付使用后,顺便跟客户提了一下我的观点,然后IT就汇报了领导,于是又要求改为:主要业务使用电信链路,其余应用就使用联通链路,当某个链路出现故障的时候,能自动切换。

打开网易新闻 查看精彩图片

客户愿意接受我的意见和建议,是值得高兴的事情,那么活儿又来了,长期外包的客户,这种事情是不会另外收费的,想问我收多少银两朋友,就别再问我了。

进正题吧,如上图所示,出口是一台华为 路由 器,接入两条宽带,分别是电信和联通,都有固定IP;下面是台华为三层 交换机 ,二层交换机就忽略了,没画出来,对我们今天要讲的内容,没什么影响。

一、路由器的配置:

第一步,配置接口IP

interface GigabitEthernet0/0/0

ip address 222.92.xx.xx 255.255.255.252

interface GigabitEthernet0/0/1

ip address 221.6.x.xxx 255.255.255.252

interface GigabitEthernet0/0/2

ip address 192.168.46.1 255.255.255.252

第二步,配置NQA,1为电信,2为联通

nqa test-instance user nqa1 //创建nqa1

test-type icmp //设置类型为icmp,也就是ping

destination-address ipv4 222.92.xx.xx //设置目标IP,也就是运营商给的网关IP

frequency 15 // 设置NQA自动执行测试的时间间隔为15秒

source-interface GigabitEthernet0/0/0 //设置源接口

start now //立即开始

nqa test-instance user nqa2

test-type icmp

destination-address ipv4 221.6.x.xxx

frequency 15

source-interface GigabitEthernet0/0/1

start now

第三步,配置默认路由与NQA联动

ip route-static 0.0.0.0 0.0.0.0 222.92.76.1 track nqa user nqa1

ip route-static 0.0.0.0 0.0.0.0 221.6.4.1 track nqa user nqa2

第四步,配置VLAN的回程路由

ip route-static 192.168.10.0 255.255.255.0 192.168.46.2

ip route-static 192.168.20.0 255.255.255.0 192.168.46.2

第五步,创建ACL指定匹配规则

acl number 3001

rule 5 permit ip source 192.168.10.0 0.0.0.255

acl number 3002

rule 5 permit ip source 192.168.20.0 0.0.0.255

第六步,配置流分类

traffic classifier ct operator or

if-match acl 3001

traffic classifier cu operator or

if-match acl 3002

第七步,配置流行为,并与NQA联动

traffic behavior ct

redirect ip-nexthop 222.92.76.1 track nqa user nqa1

traffic behavior cu

redirect ip-nexthop 221.6.4.1 track nqa user nqa2

第八步,配置流策略,绑定流分类和流行为

traffic policy tu

classifier ct behavior ct

classifier cu behavior cu

第九步,连接内网的接口应用策略

interface GigabitEthernet0/0/2

traffic-policy tu inbound

第十步,创建上网的ACL,配置easy-ip NAT

acl number 2999

rule 5 permit

interface GigabitEthernet0/0/0

nat outbound 2999

interface GigabitEthernet0/0/1

nat outbound 2999

二、交换机的配置:

vlan batch 10 20 46

dhcp enable

ip pool vlan10

gateway-list 192.168.10.1

network 192.168.10.0 mask 255.255.255.0

excluded-ip-address 192.168.10.2 192.168.10.20

dns-list 114.114.114.114

ip pool vlan20

gateway-list 192.168.20.1

network 192.168.20.0 mask 255.255.255.0

excluded-ip-address 192.168.20.2 192.168.20.20

dns-list 114.114.114.114

interface Vlanif10

ip address 192.168.10.1 255.255.255.0

dhcp select global

interface Vlanif20

ip address 192.168.20.1 255.255.255.0

dhcp select global

interface Vlanif46

ip address 192.168.46.2 255.255.255.252

interface GigabitEthernet0/0/1

port link-type access

port default vlan 46

interface GigabitEthernet0/0/2

port link-type access

port default vlan 10

interface GigabitEthernet0/0/3

port link-type access

port default vlan 20

ip route-static 0.0.0.0 0.0.0.0 192.168.46.1

三、测试

配置完成后,属于VLAN10的PC1测试上网,打开ip138网站,显示为电信IP,反之,PC2则显示为联通IP,表示选路策略配置正确;

手动断开连接电信光猫的网线,PC1也显示为联通的IP了,恢复网线连接后,流量又回到电信的链路;反之,断开联通的链路,PC2的流量也顺利切换到电信的链路了,恢复后,也会回到联通链路;抓包软件同样监测到以上切换过程,至此,表示配置正确无误。